PREGUNTERO
1 positivo 0 negativos
por (190 puntos) en Errores
¡Hola!

Estoy teniendo problemas con el audio en una netbook de Conectar igualdad Noblex SF20BA (Celeron N3060 - 4GB RAM - SSD).

El problema es el funcionamiento del micrófono integrado y la entrada de micrófono que está en combo jack de 3,5mm.

Para solucionarlo creé el archivo /etc/modprobe.d/alsa-fix.conf  y fui probando diversas entradas. Las diferentes opciones que intenté figuran en:

https://www.kernel.org/doc/html/latest/sound/hd-audio/models.html

Entiendo que el dispositivo de audio de la netbook es ALC283.

Encontré dos opciones que solucionan a medas el problema:

options snd-hda-intel model=dell-headset-multi

(Con esta funciona de manera adecuada el micrófono integrado pero no la entrada de micrófono del combo jack no funciona)

options snd-hda-intel index=0 model=alc283-sense-combo

(Con esta funcionan ambos... pero para que empiece a funcionar es necesario enchufar algo en el combo jack... esto hace que "arranque". Más allá de lo incómodo, el tema es que a veces el comportamiento es errático y deja de funcionar... por lo que hay que volver a enchufar y desenchufar algo en el jack. Supongo puede llegar a tener que ver con algo de ahorro de energía, pero no di con la opción adecuada).

También probé las siguientes opciones sin resultado:

# options snd-hda-intel model=headset-mode

# options snd-hda-intel index=0 model=laptop-amic

# options snd-hda-intel model=inv-dmic

# options snd-hda-intel model=laptop-dmic

# options snd-hda-intel model=headset-mic

# options snd-hda-intel model=alc283-int-mic

# options snd-hda-intel model=dell-headset-dock

# options snd-hda-intel model=alc283-headset

# options snd-hda-intel model=alc283-dac-wcaps

# options snd-hda-intel model=aspire-headset-mic

# options snd-hda-intel model=alc-sense-combo

# options snd-hda-intel model=alc283-int-mic

# options snd-hda-intel model=auto

Probé algunas otras, pero no las registré en mis pruebas...

¿Alguien encontró alguna solución?

2 Respuestas

0 positivos 0 negativos
por (2,9m puntos)

Probaste por acá:

por (190 puntos)
Sí... probé cambiando las intensidades y seleccionando el conector... nada...
por (2,9m puntos)
Para verificar si no es un problema físico ¿tenés en esa compu una partición con otro SO? En una de esas probando, por ejemplo con W10 lite, podrás saber si el problema es en linux o de hardware.
por (190 puntos)
En windows funciona sin problemas.
por (2,9m puntos)
0 positivos 0 negativos
por (880 puntos)
En esos modelos me funcionaba con la opción laptop-amic

options snd-hda-intel model=laptop-amic

Pero veo que la probaste sin resultado favorable.

Qué versión de Huayra estás usando?

Verificá también si tenés el paquete firmware-intel-sound
¡Bienvenidas y bienvenidos a la ayuda comunitaria de Huayra! Aquí podrás hacer preguntas y también aportar respuestas para hacer crecer esta comunidad basada en este sistema operativo educativo, libre y federal.

40 preguntas

76 respuestas

49 comentarios

1,0m usuarios

...