PREGUNTERO
7 positivos 0 negativos
por Recién Llegadx.... (380 puntos) en Aplicaciones
hola, buenas tardes

hoy consulto esto debido a que al intentar instalar el archivo de theft deterrent guardian 6.0 hecho con dpkg repack (en linux mint 21.1) tiene un problema con dependencias en el gestor de paquetes Gdebi, en especifico, python (>=2.6)

tengo instalado python 3 en la pc y tambien tengo los repositorios del programa

no habra un usuario que tenga la amabilidad de pasarme los archivos de una version mas vieja de huayra por favor?

4 Respuestas

4 positivos 0 negativos
por Huayra Ninja (21,5m puntos)
2 positivos 0 negativos
por Recién Llegadx.... (330 puntos)
Yo no he podido instalar el Theftdeterrent en ninguna distribucion derivada de ubuntu/debian, ni en linux mint ni en kde neon, ni en ubuntu oficial ni en ninguno. En todos da el mismo error que mencionas y no he encontrado la solucion a eso aun y he probado varias cosas como instalar varias versiones de python por ejemplo y nada. En cambio en arch linux si me funciono, tambien en manjaro (deribado de arch), basicamente lo logre reempaquetando el agente desde huayra en archivos .deb (son 4 paquetes), luego copie los paquetes a mi carpeta personal de manjaro y los converti con el programa debtap, luego los instale y funciono todo espectacular! me tomo los arranques de una. De paso te invito a probar manjaro, funciona muchisimo mas rapido que mint y encontraras menos errores, almenos esa fue mi experiencia
por Recién Llegadx.... (330 puntos)
Adjunto una imagen de como quedo (Es manjaro, con un pack de iconos personalizado) https://drive.google.com/file/d/1AdhOveCGShxG68HsopO-4L-vlkxymV-j/view?usp=sharing
2 positivos 0 negativos
por Recién Llegadx.... (770 puntos)
Acá hay instrucciones de cómo hacerlo en distintos sistemas operativos

https://github.com/Jotalea/TheftDeterrent
por Recién Llegadx.... (330 puntos)
Sigue dando error de dependencias desde huayra 6.5, instalandolo manualmente desde los paquetes .deb y tambien desde synaptic da el mismo error mencionado en el post. Te invito a probarlo tu mismo, pero debes hacerlo desde un so instalado desde 0.
2 positivos 0 negativos
por Recién Llegadx.... (220 puntos)
editado por
Hola, aca resolvi el problema de dependencias del python en debian (pude instalarlo en loc-os), ya

esta en empaquetado el nuevo guardian para poder instalarlo (para versiones de python3), si quieren pueden modificar para su version de python con las instrucciones que proporcione:

https://github.com/Maxel4ss4rt3/Theftdeterrent_debian
por Recién Llegadx.... (330 puntos)
editado por
Es solo una solucion parcial, yo hice los pasos tal cual y esta vez no hubo problemas de dependencias, pero el agente solo toma los arranque una vez, al reiniciar vuelve a verse gris y a no conectar, por lo tanto hay que repetir todos los pasos que mencionaste en la ultima seccion "Error no se conecta al servidor" cada vez que se arranque el sistema. Ademas en mi caso, hacerlo tal cual lo mencionaste no funciono, solo funciona cuando reinstalo los 4 paquetes (me aparece el PID) y solo asi puedo conectar y hacer que me de arranques, pero repito esto funciona solo hasta que reinicias, luego vuelve a verse gris y hay que repetir todo. Lo probe tanto en huayra 6.5 como en loc os.
EDIT: ya funciona en todas las distros debian con systemd (huayra, mint, ubuntu, zorin, kde neon, etc) pero en loc os persiste el problema al reiniciar, como tambien en antix.. tendra algo que ver con systemd?
¡Bienvenidas y bienvenidos a la ayuda comunitaria de Huayra! Aquí podrás hacer preguntas y también aportar respuestas para hacer crecer esta comunidad basada en este sistema operativo educativo, libre y federal.

Recordá que para realizar una pregunta, primero debes alcanzar 130 puntos por medio de la votación de algunas de las preguntas o respuestas existentes.

275 preguntas

424 respuestas

306 comentarios

32,9m usuarios

...